CVE-2017-15587

NameCVE-2017-15587
DescriptionAn integer overflow was discovered in pdf_read_new_xref_section in pdf/pdf-xref.c in Artifex MuPDF 1.11.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1164-1, DSA-4006-1, DSA-4006-2
NVD severitymedium (attack range: remote)
Debian Bugs879055

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mupdf (PTS)jessie1.5-1+deb8u4fixed
jessie (security)1.5-1+deb8u6fixed
stretch (security), stretch1.9a+ds1-4+deb9u4fixed
buster1.14.0+ds1-4fixed
bullseye, sid1.15.0+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mupdfsource(unstable)1.11+ds1-2medium879055
mupdfsourcejessie1.5-1+deb8u3mediumDSA-4006-2
mupdfsourcestretch1.9a+ds1-4+deb9u2mediumDSA-4006-2
mupdfsourcewheezy0.9-2+deb7u4mediumDLA-1164-1

Notes

http://git.ghostscript.com/?p=mupdf.git;h=82df2631d7d0446b206ea6b434ea609b6c28b0e8
https://bugs.ghostscript.com/show_bug.cgi?id=698605 (not public)
https://nandynarwhals.org/CVE-2017-15587/

Search for package or bug name: Reporting problems