CVE-2017-15589

NameCVE-2017-15589
DescriptionAn issue was discovered in Xen through 4.9.x allowing x86 HVM guest OS users to obtain sensitive information from the host OS (or an arbitrary guest OS) because intercepted I/O operations can cause a write of data from uninitialized hypervisor stack memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1181-1, DSA-4050-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-10fixed
jessie, jessie (security)4.4.1-9+deb8u10vulnerable
buster, sid, stretch, stretch (security)4.8.2+xsa245-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.2+xsa245-0+deb9u1low
xensourcestretch4.8.2+xsa245-0+deb9u1lowDSA-4050-1
xensourcewheezy4.1.6.lts1-10lowDLA-1181-1

Notes

https://xenbits.xen.org/xsa/advisory-239.html

Search for package or bug name: Reporting problems