CVE-2017-15591

NameCVE-2017-15591
DescriptionAn issue was discovered in Xen 4.5.x through 4.9.x allowing attackers (who control a stub domain kernel or tool stack) to cause a denial of service (host OS crash) because of a missing comparison (of range start to range end) within the DMOP map/unmap implementation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4050-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10fixed
jessie (security)4.4.4lts4-0+deb8u1fixed
stretch (security), stretch4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10fixed
buster, sid4.11.1~pre.20180911.5acdd26fdc+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.2+xsa245-0+deb9u1medium
xensourcejessie(not affected)
xensourcestretch4.8.2+xsa245-0+deb9u1mediumDSA-4050-1
xensourcewheezy(not affected)

Notes

[jessie] - xen <not-affected> (Only affects 4.5 and later)
[wheezy] - xen <not-affected> (Only affects 4.5 and later)
https://xenbits.xen.org/xsa/advisory-238.html

Search for package or bug name: Reporting problems