CVE-2017-15592

NameCVE-2017-15592
DescriptionAn issue was discovered in Xen through 4.9.x allowing x86 HVM guest OS users to cause a denial of service (hypervisor crash) or possibly gain privileges because self-linear shadow mappings are mishandled for translated guests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1181-1, DLA-1559-1, DSA-4050-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)stretch, stretch (security)4.8.5.final+shim4.10.4-1+deb9u12fixed
buster, buster (security)4.11.4+24-gddaaccbbab-1~deb10u1fixed
bullseye, sid4.11.4+24-gddaaccbbab-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensourcewheezy4.1.6.lts1-10DLA-1181-1
xensourcejessie4.4.4lts3-0+deb8u1DLA-1559-1
xensourcestretch4.8.2+xsa245-0+deb9u1DSA-4050-1
xensource(unstable)4.8.2+xsa245-0+deb9u1

Notes

https://xenbits.xen.org/xsa/advisory-243.html

Search for package or bug name: Reporting problems