CVE-2017-15642

NameCVE-2017-15642
DescriptionIn lsx_aiffstartread in aiff.c in Sound eXchange (SoX) 14.4.2, there is a Use-After-Free vulnerability triggered by supplying a malformed AIFF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1197-1, DLA-1695-1
NVD severitymedium
Debian Bugs882144

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sox (PTS)jessie14.4.1-5vulnerable
jessie (security)14.4.1-5+deb8u4fixed
stretch14.4.1-5+deb9u2fixed
buster14.4.2+git20190427-1fixed
bullseye, sid14.4.2+git20190427-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soxsource(unstable)14.4.2-2882144
soxsourcejessie14.4.1-5+deb8u2DLA-1695-1
soxsourcestretch14.4.1-5+deb9u2
soxsourcewheezy14.4.0-3+deb7u2DLA-1197-1

Notes

https://sourceforge.net/p/sox/bugs/298/
https://github.com/mansr/sox/commit/0be259eaa9ce3f3fa587a3ef0cf2c0b9c73167a2

Search for package or bug name: Reporting problems