CVE-2017-15672

NameCVE-2017-15672
DescriptionThe read_header function in libavcodec/ffv1dec.c in FFmpeg 3.3.4 and earlier allows remote attackers to have unspecified impact via a crafted MP4 file, which triggers an out-of-bounds read.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.7-1~deb9u1vulnerable
stretch (security)7:3.2.8-1~deb9u1vulnerable
buster7:3.4-2fixed
sid7:3.4-3fixed
libav (PTS)wheezy6:0.8.17-2undetermined
wheezy (security)6:0.8.21-0+deb7u1undetermined
jessie6:11.9-1~deb8u1undetermined
jessie (security)6:11.11-1~deb8u1undetermined

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:3.4-1
libavsource(unstable)undetermined

Notes

[stretch] - ffmpeg <postponed> (Wait until next round of security releases)
Fixed by: http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=c20f4fcb74da2d0432c7b54499bb98f48236b904

Search for package or bug name: Reporting problems