CVE-2017-15706

NameCVE-2017-15706
DescriptionAs part of the fix for bug 61201, the documentation for Apache Tomcat 9.0.0.M22 to 9.0.1, 8.5.16 to 8.5.23, 8.0.45 to 8.0.47 and 7.0.79 to 7.0.82 included an updated description of the search algorithm used by the CGI Servlet to identify which script to execute. The update was not correct. As a result, some scripts may have failed to execute as expected and other scripts may have been executed unexpectedly. Note that the behaviour of the CGI servlet has remained unchanged in this regard. It is only the documentation of the behaviour that was wrong and has been corrected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat7 (PTS)jessie7.0.56-3+deb8u11fixed
jessie (security)7.0.56-3+really7.0.91-1fixed
stretch7.0.75-1fixed
tomcat8 (PTS)jessie8.0.14-1+deb8u11fixed
jessie (security)8.0.14-1+deb8u14fixed
stretch (security), stretch8.5.14-1+deb9u3fixed
buster, sid8.5.35-2fixed
tomcat9 (PTS)buster9.0.13-2fixed
sid9.0.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat7source(unstable)(not affected)
tomcat8source(unstable)8.5.24-1medium
tomcat8sourcejessie(not affected)
tomcat8sourcestretch(not affected)
tomcat8.0source(unstable)(unfixed)unimportant
tomcat9source(unstable)(not affected)

Notes

- tomcat9 <not-affected> (Fixed before initial upload to Debian)
[stretch] - tomcat8 <not-affected> (Issue introduced later)
[jessie] - tomcat8 <not-affected> (Issue introduced later)
tomcat8.0 builds only tomcat8.0-user and libtomcat8.0-java
- tomcat7 <not-affected> (Only affects 7.0.79 to 7.0.82, Upstream bugzilla entry bz#61201 not addressed)
https://svn.apache.org/r1814828 (7.0.x)
https://svn.apache.org/r1814827 (8.0.x)
https://svn.apache.org/r1814826 (8.5.x)
Introduced by fix for https://bz.apache.org/bugzilla/show_bug.cgi?id=61201
https://lists.apache.org/thread.html/e1ef853fc0079cdb55befbd2dac042934e49288b476d5f6a649e5da2@%3Cannounce.tomcat.apache.org%3E

Search for package or bug name: Reporting problems