CVE-2017-15736

NameCVE-2017-15736
DescriptionCross-site scripting (XSS) vulnerability (stored) in SPIP before 3.1.7 allows remote attackers to inject arbitrary web script or HTML via a crafted string, as demonstrated by a PGP field, related to prive/objets/contenu/auteur.html and ecrire/inc/texte_mini.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4228-1
NVD severitymedium
Debian Bugs879954

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)stretch (security), stretch3.1.4-4~deb9u3fixed
buster, buster (security)3.2.4-1+deb10u2fixed
bullseye, sid3.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcewheezy(not affected)
spipsourcejessie3.0.17-2+deb8u4DSA-4228-1
spipsourcestretch3.1.4-4~deb9u1DSA-4228-1
spipsource(unstable)3.1.4-4879954

Notes

[wheezy] - spip <not-affected> (vulnerable code not present)
https://core.spip.net/projects/spip/repository/revisions/23701

Search for package or bug name: Reporting problems