DescriptionCross-site scripting (XSS) vulnerability (stored) in SPIP before 3.1.7 allows remote attackers to inject arbitrary web script or HTML via a crafted string, as demonstrated by a PGP field, related to prive/objets/contenu/auteur.html and ecrire/inc/texte_mini.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs879954

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)wheezy2.1.17-1+deb7u5fixed
wheezy (security)2.1.17-1+deb7u8fixed
jessie (security)3.0.17-2+deb8u2vulnerable
stretch (security), stretch3.1.4-3~deb9u1vulnerable
buster, sid3.1.4-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcewheezy(not affected)


[stretch] - spip <no-dsa> (Minor issue)
[jessie] - spip <no-dsa> (Minor issue)
[wheezy] - spip <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems