CVE-2017-15804

NameCVE-2017-15804
DescriptionThe glob function in glob.c in the GNU C Library (aka glibc or libc6) before 2.27 contains a buffer overflow during unescaping of user names with the ~ operator.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs879955

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
eglibc (PTS)wheezy2.13-38+deb7u10vulnerable
wheezy (security)2.13-38+deb7u12vulnerable
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch (security), stretch2.24-11+deb9u1vulnerable
buster2.26-2fixed
sid2.26-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)low
glibcsource(unstable)2.25-3low879955

Notes

[stretch] - glibc <no-dsa> (Minor issue)
[jessie] - glibc <no-dsa> (Minor issue)
[wheezy] - eglibc <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=22332
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commit;h=a159b53fa059947cc2548e3b0d5bdcf7b9630ba8

Search for package or bug name: Reporting problems