CVE-2017-15922

NameCVE-2017-15922
DescriptionIn GNU Libextractor 1.4, there is an out-of-bounds read in the EXTRACTOR_dvi_extract_method function in plugins/dvi_extractor.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1198-1
NVD severitymedium (attack range: remote)
Debian Bugs880016

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libextractor (PTS)jessie1:1.3-2+deb8u1fixed
jessie (security)1:1.3-2+deb8u4fixed
stretch1:1.3-4+deb9u2fixed
stretch (security)1:1.3-4+deb9u3fixed
buster, sid1:1.8-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libextractorsource(unstable)1:1.6-2low880016
libextractorsourcejessie1:1.3-2+deb8u1medium
libextractorsourcestretch1:1.3-4+deb9u1medium
libextractorsourcewheezy1:0.6.3-5+deb7u1mediumDLA-1198-1

Notes

http://lists.gnu.org/archive/html/bug-libextractor/2017-10/msg00008.html
Fixed by: https://gnunet.org/git/libextractor.git/commit/?id=d4d488b0e5ab13dda241d688d87a07816368f117

Search for package or bug name: Reporting problems