CVE-2017-16042

NameCVE-2017-16042
DescriptionGrowl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs900868

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-growl (PTS)jessie, stretch1.7.0-1vulnerable
buster, sid1.10.5-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-growlsource(unstable)1.10.5-1unimportant900868

Notes

Issue: https://github.com/tj/node-growl/issues/60
https://github.com/tj/node-growl/pull/61
https://nodesecurity.io/advisories/146
nodejs not covered by security support

Search for package or bug name: Reporting problems