CVE-2017-16137

NameCVE-2017-16137
DescriptionThe debug module is vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. It takes around 50k characters to block for 2 seconds making this a low severity issue.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-debug (PTS)buster3.1.0-2fixed
bullseye4.3.1+~cs4.1.5-1fixed
bookworm, sid4.3.4+~cs4.1.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-debugsource(unstable)3.1.0-1unimportant

Notes

https://nodesecurity.io/advisories/534
nodejs not covered by security support

Search for package or bug name: Reporting problems