CVE-2017-16248

NameCVE-2017-16248
DescriptionThe Catalyst-Plugin-Static-Simple module before 0.34 for Perl allows remote attackers to read arbitrary files if there is a '.' character anywhere in the pathname, which differs from the intended policy of allowing access only when the filename itself has a '.' character.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs880458

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcatalyst-plugin-static-simple-perl (PTS)jessie0.32-1vulnerable
stretch0.33-1vulnerable
buster, sid0.34-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcatalyst-plugin-static-simple-perlsource(unstable)0.34-1medium880458

Notes

[stretch] - libcatalyst-plugin-static-simple-perl <no-dsa> (Minor issue)
[jessie] - libcatalyst-plugin-static-simple-perl <no-dsa> (Minor issue)
https://rt.cpan.org/Public/Bug/Display.html?id=120558

Search for package or bug name: Reporting problems