CVE-2017-16664

NameCVE-2017-16664
DescriptionCode injection exists in Kernel/System/Spelling.pm in Open Ticket Request System (OTRS) 5 before 5.0.24, 4 before 4.0.26, and 3.3 before 3.3.20. In the agent interface, an authenticated remote attacker can execute shell commands as the webserver user via URL manipulation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1212-1, DSA-4047-1
NVD severitymedium (attack range: remote)
Debian Bugs882370

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
otrs2 (PTS)stretch/non-free5.0.16-1+deb9u3fixed
sid/non-free, buster/non-free6.0.3-1fixed
stretch/non-free (security)5.0.16-1+deb9u5fixed
wheezy3.1.7+dfsg1-8+deb7u5vulnerable
wheezy (security)3.3.18-1~deb7u3fixed
jessie3.3.18-1+deb8u2fixed
jessie (security)3.3.18-1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
otrs2source(unstable)5.0.24-1medium882370
otrs2sourcejessie3.3.18-1+deb8u2mediumDSA-4047-1
otrs2sourcestretch5.0.16-1+deb9u3mediumDSA-4047-1
otrs2sourcewheezy3.3.18-1~deb7u2mediumDLA-1212-1

Notes

https://www.otrs.com/security-advisory-2017-07-security-update-otrs-framework/
OTRS 5: https://github.com/OTRS/otrs/commit/4c36932d0c42343f21246a107e17a2ebbd9c2c7d
OTRS 3.3: https://github.com/OTRS/otrs/commit/2e58a4bbd99b2477d72c3b2d9fef009537ab19ce

Search for package or bug name: Reporting problems