CVE-2017-16785

NameCVE-2017-16785
DescriptionCacti 1.1.27 has reflected XSS via the PATH_INFO to host.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)stretch (security), stretch0.8.8h+ds1-10+deb9u1fixed
buster1.2.2+ds1-2+deb10u4fixed
buster (security)1.2.2+ds1-2+deb10u2fixed
bullseye, sid1.2.16+ds1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisourcewheezy(not affected)
cactisourcejessie(not affected)
cactisourcestretch(not affected)
cactisource(unstable)1.1.27+ds1-3

Notes

[stretch] - cacti <not-affected> (Vulnerable code does not exist)
[jessie] - cacti <not-affected> (Vulnerable code does not exist)
[wheezy] - cacti <not-affected> (Vulnerable code does not exist)
https://github.com/Cacti/cacti/issues/1071
this is more or less a dublicate of CVE-2017-16641
one of the applied patches reopened the vulnerability

Search for package or bug name: Reporting problems