CVE-2017-16803

NameCVE-2017-16803
DescriptionIn Libav through 11.11 and 12.x through 12.1, the smacker_decode_tree function in libavcodec/smacker.c does not properly restrict tree recursion, which allows remote attackers to cause a denial of service (bitstream.c:build_table() out-of-bounds read and application crash) via a crafted Smacker stream.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.7-1~deb9u1vulnerable
stretch (security)7:3.2.8-1~deb9u1vulnerable
buster7:3.4-2vulnerable
sid7:3.4-3vulnerable
libav (PTS)wheezy6:0.8.17-2vulnerable
wheezy (security)6:0.8.21-0+deb7u1vulnerable
jessie6:11.9-1~deb8u1vulnerable
jessie (security)6:11.11-1~deb8u1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)(unfixed)low
libavsource(unstable)(unfixed)low

Notes

[stretch] - ffmpeg <postponed> (Can be fixed with next 3.2.x release)
https://bugzilla.libav.org/show_bug.cgi?id=1098
https://github.com/libav/libav/commit/cd4663dc80323ba64989d0c103d51ad3ee0e9c2f
https://git.ffmpeg.org/gitweb/ffmpeg.git/commit/cd4663dc80323ba64989d0c103d51ad3ee0e9c2f

Search for package or bug name: Reporting problems