CVE-2017-16816

NameCVE-2017-16816
DescriptionThe condor_schedd component in HTCondor before 8.6.8 and 8.7.x before 8.7.5 allows remote authenticated users to cause a denial of service (daemon crash) by leveraging use of GSI and VOMS extensions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
condor (PTS)jessie8.2.3~dfsg.1-6vulnerable
stretch8.4.11~dfsg.1-1fixed
buster, bullseye, sid8.6.8~dfsg.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
condorsource(unstable)8.6.8~dfsg.1-1medium
condorsourcestretch(not affected)

Notes

[stretch] - condor <not-affected> (VOMS support disabled)
[jessie] - condor <no-dsa> (Minor issue)
[wheezy] - condor <no-dsa> (Minor issue)
http://research.cs.wisc.edu/htcondor//security/vulnerabilities/HTCONDOR-2017-0001.html

Search for package or bug name: Reporting problems