CVE-2017-16909

NameCVE-2017-16909
DescriptionAn error related to the "LibRaw::panasonic_load_raw()" function (dcraw_common.cpp) in LibRaw versions prior to 0.18.6 can be exploited to cause a heap-based buffer overflow and subsequently cause a crash via a specially crafted TIFF image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libraw (PTS)jessie0.16.0-9+deb8u3vulnerable
jessie (security)0.16.0-9+deb8u4vulnerable
stretch (security), stretch0.17.2-6+deb9u1vulnerable
buster0.19.2-2fixed
bullseye, sid0.19.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
librawsource(unstable)0.18.6-1medium

Notes

[stretch] - libraw <no-dsa> (Minor issue)
[jessie] - libraw <no-dsa> (Minor issue)
[wheezy] - libraw <no-dsa> (Minor issue)
https://secuniaresearch.flexerasoftware.com/secunia_research/2017-19
https://github.com/LibRaw/LibRaw/commit/2f59bac59dbcbf6bbcf01a9f3eed74307e96ca7e

Search for package or bug name: Reporting problems