CVE-2017-16944

NameCVE-2017-16944
DescriptionThe receive_msg function in receive.c in the SMTP daemon in Exim 4.88 and 4.89 allows remote attackers to cause a denial of service (infinite loop and stack exhaustion) via vectors involving BDAT commands and an improper check for a '.' character signifying the end of the content, related to the bdat_getc function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4053-1
NVD severitymedium (attack range: remote)
Debian Bugs882671

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)wheezy4.80-7+deb7u3fixed
wheezy (security)4.80-7+deb7u5fixed
jessie, jessie (security)4.84.2-2+deb8u4fixed
stretch, stretch (security)4.89-2+deb9u2fixed
buster4.90~RC3-2fixed
sid4.90~RC4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exim4source(unstable)4.89-13medium882671
exim4sourcejessie(not affected)
exim4sourcestretch4.89-2+deb9u2mediumDSA-4053-1
exim4sourcewheezy(not affected)

Notes

[jessie] - exim4 <not-affected> (ESMTP CHUNKING extension introduced in 4.88)
[wheezy] - exim4 <not-affected> (ESMTP CHUNKING extension introduced in 4.88)
https://bugs.exim.org/show_bug.cgi?id=2201
https://git.exim.org/exim.git/commitdiff/178ecb70987f024f0e775d87c2f8b2cf587dd542
https://lists.exim.org/lurker/message/20171125.034842.d1d75cac.en.html
4.89-10 adds a workaround which disables the affected code by default

Search for package or bug name: Reporting problems