CVE-2017-17044

NameCVE-2017-17044
DescriptionAn issue was discovered in Xen through 4.9.x allowing HVM guest OS users to cause a denial of service (infinite loop and host OS hang) by leveraging the mishandling of Populate on Demand (PoD) errors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4050-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9vulnerable
wheezy (security)4.1.6.lts1-10vulnerable
jessie, jessie (security)4.4.1-9+deb8u10vulnerable
buster, sid, stretch, stretch (security)4.8.2+xsa245-0+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.2+xsa245-0+deb9u1
xensourcestretch4.8.2+xsa245-0+deb9u1DSA-4050-1

Notes

https://xenbits.xen.org/xsa/advisory-246.html

Search for package or bug name: Reporting problems