CVE-2017-17091

NameCVE-2017-17091
Descriptionwp-admin/user-new.php in WordPress before 4.9.1 sets the newbloguser key to a string that can be directly derived from the user ID, which allows remote attackers to bypass intended access restrictions by entering this string.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1216-1, DSA-4090-1
NVD severitymedium (attack range: remote)
Debian Bugs883314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)wheezy3.6.1+dfsg-1~deb7u10vulnerable
wheezy (security)3.6.1+dfsg-1~deb7u20fixed
jessie4.1+dfsg-1+deb8u15vulnerable
jessie (security)4.1+dfsg-1+deb8u16fixed
stretch4.7.5+dfsg-2+deb9u1vulnerable
stretch (security)4.7.5+dfsg-2+deb9u2fixed
buster, sid4.9.2+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.1+dfsg-1medium883314
wordpresssourcejessie4.1+dfsg-1+deb8u16mediumDSA-4090-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u2mediumDSA-4090-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u20mediumDLA-1216-1

Notes

https://github.com/WordPress/WordPress/commit/eaf1cfdc1fe0bdffabd8d879c591b864d833326c
https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems