CVE-2017-17092

NameCVE-2017-17092
Descriptionwp-includes/functions.php in WordPress before 4.9.1 does not require the unfiltered_html capability for upload of .js files, which might allow remote attackers to conduct XSS attacks via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1216-1, DSA-4090-1
Debian Bugs883314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)buster5.0.15+dfsg1-0+deb10u1fixed
buster (security)5.0.21+dfsg1-0+deb10u1fixed
bullseye5.7.8+dfsg1-0+deb11u2fixed
bullseye (security)5.7.11+dfsg1-0+deb11u1fixed
bookworm6.1.1+dfsg1-1fixed
bookworm (security)6.1.6+dfsg1-0+deb12u1fixed
sid, trixie6.5.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssourcewheezy3.6.1+dfsg-1~deb7u20DLA-1216-1
wordpresssourcejessie4.1+dfsg-1+deb8u16DSA-4090-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u2DSA-4090-1
wordpresssource(unstable)4.9.1+dfsg-1883314

Notes

https://github.com/WordPress/WordPress/commit/67d03a98c2cae5f41843c897f206adde299b0509
https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems