CVE-2017-17093

NameCVE-2017-17093
Descriptionwp-includes/general-template.php in WordPress before 4.9.1 does not properly restrict the lang attribute of an HTML element, which might allow attackers to conduct XSS attacks via the language setting of a site.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1216-1, DSA-4090-1
NVD severitylow (attack range: remote)
Debian Bugs883314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17fixed
jessie (security)4.1+dfsg-1+deb8u18fixed
stretch4.7.5+dfsg-2+deb9u3fixed
stretch (security)4.7.5+dfsg-2+deb9u4fixed
buster, sid4.9.8+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.1+dfsg-1low883314
wordpresssourcejessie4.1+dfsg-1+deb8u16lowDSA-4090-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u2lowDSA-4090-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u20lowDLA-1216-1

Notes

https://github.com/WordPress/WordPress/commit/3713ac5ebc90fb2011e98dfd691420f43da6c09a
https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems