CVE-2017-17094

NameCVE-2017-17094
Descriptionwp-includes/feed.php in WordPress before 4.9.1 does not properly restrict enclosures in RSS and Atom fields, which might allow attackers to conduct XSS attacks via a crafted URL.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1216-1, DSA-4090-1
NVD severitylow (attack range: remote)
Debian Bugs883314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie (security), jessie4.1+dfsg-1+deb8u17fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u3fixed
buster, sid4.9.7+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)4.9.1+dfsg-1low883314
wordpresssourcejessie4.1+dfsg-1+deb8u16lowDSA-4090-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u2lowDSA-4090-1
wordpresssourcewheezy3.6.1+dfsg-1~deb7u20lowDLA-1216-1

Notes

https://github.com/WordPress/WordPress/commit/f1de7e42df29395c3314bf85bff3d1f4f90541de
https://wordpress.org/news/2017/11/wordpress-4-9-1-security-and-maintenance-release/

Search for package or bug name: Reporting problems