CVE-2017-17381

NameCVE-2017-17381
DescriptionThe Virtio Vring implementation in QEMU allows local OS guest users to cause a denial of service (divide-by-zero error and QEMU process crash) by unsetting vring alignment while updating Virtio rings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4213-1
NVD severitylow (attack range: local)
Debian Bugs883625

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6fixed
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.11+dfsg-1low883625
qemusourcejessie(not affected)
qemusourcestretch1:2.8+dfsg-6+deb9u4lowDSA-4213-1
qemu-kvmsource(unstable)(unfixed)low

Notes

[jessie] - qemu <not-affected> (Vulnerable code not present)
[wheezy] - qemu <postponed> (Can be fixed along in later update)
[wheezy] - qemu-kvm <postponed> (Can be fixed along in later update)
https://lists.gnu.org/archive/html/qemu-devel/2017-12/msg00166.html

Search for package or bug name: Reporting problems