CVE-2017-17507

NameCVE-2017-17507
DescriptionIn HDF5 1.10.1, there is an out of bounds read vulnerability in the function H5T_conv_struct_opt in H5Tconv.c in libhdf5.a. For example, h5dump would crash when someone opens a crafted hdf5 file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs915807

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hdf5 (PTS)jessie (security), jessie1.8.13+docs-15+deb8u1vulnerable
stretch1.10.0-patch1+docs-3+deb9u1vulnerable
bullseye, buster, sid1.10.4+repack-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hdf5source(unstable)(unfixed)low915807

Notes

[buster] - hdf5 <no-dsa> (Minor issue, requires ABI change)
[stretch] - hdf5 <no-dsa> (Minor issue)
[jessie] - hdf5 <no-dsa> (Minor issue)
[wheezy] - hdf5 <no-dsa> (Minor issue)
POC: https://github.com/xiaoqx/pocs/blob/master/hdf5/3-hdf5-outbound-read-H5T_conv_struct_opt
https://github.com/xiaoqx/pocs/blob/master/hdf5/readme.md
Fixing the bug requires an ABI changes thus upstream will only include a fix
on a major version bump.

Search for package or bug name: Reporting problems