CVE-2017-17511

NameCVE-2017-17511
DescriptionKildClient 3.1.0 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, related to prefs.c and worldgui.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1210-1
NVD severitymedium (attack range: remote)
Debian Bugs885007

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kildclient (PTS)jessie3.0.0-2vulnerable
stretch3.1.0-1+deb9u1fixed
buster, sid3.2.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kildclientsource(unstable)3.2.0-1medium885007
kildclientsourcestretch3.1.0-1+deb9u1medium
kildclientsourcewheezy2.11.1-1+deb7u1mediumDLA-1210-1

Notes

[jessie] - kildclient <no-dsa> (Minor issue)
https://sources.debian.org/src/kildclient/3.1.0-1/src/worldgui.c/?hl=1159#L1159
https://sources.debian.org/src/kildclient/3.1.0-1/src/prefs.c/?hl=324#L324

Search for package or bug name: Reporting problems