CVE-2017-17523

NameCVE-2017-17523
Descriptionlilypond-invoke-editor in LilyPond 2.19.80 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs884136

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lilypond (PTS)wheezy2.14.2-4vulnerable
jessie2.18.2-4vulnerable
buster, sid2.18.2-11vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lilypondsource(unstable)(unfixed)medium884136

Notes

[jessie] - lilypond <no-dsa> (Minor issue)
[wheezy] - lilypond <no-dsa> (Minor issue)
https://sourceforge.net/p/testlilyissues/issues/5243/

Search for package or bug name: Reporting problems