CVE-2017-17563

NameCVE-2017-17563
DescriptionAn issue was discovered in Xen through 4.9.x allowing guest OS users to cause a denial of service (host OS crash) or gain host OS privileges by leveraging an incorrect mask for reference-count overflow checking in shadow mode.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1230-1, DSA-4112-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)jessie4.4.1-9+deb8u10vulnerable
jessie (security)4.4.4lts1-0+deb8u1vulnerable
buster, sid, stretch4.8.3+xsa267+shim4.10.1+xsa267-1+deb9u9fixed
stretch (security)4.8.4+xsa273+shim4.10.1+xsa273-1+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.8.3+comet2+shim4.10.0+comet3-1+deb9u5medium
xensourcestretch4.8.3+comet2+shim4.10.0+comet3-1+deb9u4.1mediumDSA-4112-1
xensourcewheezy4.1.6.lts1-11mediumDLA-1230-1

Notes

https://xenbits.xen.org/xsa/advisory-249.html

Search for package or bug name: Reporting problems