CVE-2017-17740

NameCVE-2017-17740
Descriptioncontrib/slapd-modules/nops/nops.c in OpenLDAP through 2.4.45, when both the nops module and the memberof overlay are enabled, attempts to free a buffer that was allocated on the stack, which allows remote attackers to cause a denial of service (slapd crash) via a member MODDN operation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openldap (PTS)wheezy2.4.31-2+deb7u2vulnerable
wheezy (security)2.4.31-2+deb7u3vulnerable
jessie (security), jessie2.4.40+dfsg-1+deb8u3vulnerable
stretch2.4.44+dfsg-5+deb9u1vulnerable
buster, sid2.4.45+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openldapsource(unstable)(unfixed)unimportant

Notes

http://www.openldap.org/its/index.cgi/Incoming?id=8759
nops slapd-module not built

Search for package or bug name: Reporting problems