CVE-2017-17741

NameCVE-2017-17741
DescriptionThe KVM implementation in the Linux kernel through 4.14.7 allows attackers to obtain potentially sensitive information from kernel memory, aka a write_mmio stack-based out-of-bounds read, related to arch/x86/kvm/x86.c and include/trace/events/kvm.h.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1232-1, DSA-4073-1, DSA-4082-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie (security), jessie3.16.56-1+deb8u1fixed
stretch4.9.82-1+deb9u3fixed
stretch (security)4.9.88-1+deb9u1fixed
buster4.16.12-1fixed
sid4.16.16-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.14.7-1low
linuxsourcejessie3.16.51-3+deb8u1lowDSA-4082-1
linuxsourcestretch4.9.65-3+deb9u1lowDSA-4073-1
linuxsourcewheezy3.2.96-3lowDLA-1232-1

Notes

https://www.spinics.net/lists/kvm/msg160796.html

Search for package or bug name: Reporting problems