CVE-2017-17760

NameCVE-2017-17760
DescriptionOpenCV 3.3.1 has a Buffer Overflow in the cv::PxMDecoder::readData function in grfmt_pxm.cpp, because an incorrect size value is used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1235-1
NVD severitymedium (attack range: remote)
Debian Bugs885843

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opencv (PTS)wheezy2.3.1-11+deb7u1vulnerable
wheezy (security)2.3.1-11+deb7u4fixed
jessie2.4.9.1+dfsg-1+deb8u1vulnerable
stretch2.4.9.1+dfsg1-2vulnerable
buster, sid3.2.0+dfsg-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opencvsource(unstable)(unfixed)medium885843
opencvsourcewheezy2.3.1-11+deb7u3mediumDLA-1235-1

Notes

https://github.com/opencv/opencv/issues/10351
https://github.com/opencv/opencv/pull/10369/commits/7bbe1a53cfc097b82b1589f7915a2120de39274c

Search for package or bug name: Reporting problems