CVE-2017-17783

NameCVE-2017-17783
DescriptionIn GraphicsMagick 1.3.27a, there is a buffer over-read in ReadPALMImage in coders/palm.c when QuantumDepth is 8.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs884904

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8vulnerable
buster, sid1.3.29+hg15665-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.27-2medium884904
graphicsmagicksourcewheezy(not affected)

Notes

[stretch] - graphicsmagick <no-dsa> (Minor issue, built with QuantumDepth=16)
[jessie] - graphicsmagick <no-dsa> (Minor issue)
[wheezy] - graphicsmagick <not-affected> (vulnerable code not present, unreproducible with ASAN)
http://hg.graphicsmagick.org/hg/GraphicsMagick?cmd=changeset;node=60932931559a
https://sourceforge.net/p/graphicsmagick/bugs/529/

Search for package or bug name: Reporting problems