CVE-2017-17805

NameCVE-2017-17805
DescriptionThe Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executing a crafted sequence of system calls that use the blkcipher_walk API. Both the generic implementation (crypto/salsa20_generic.c) and x86 implementation (arch/x86/crypto/salsa20_glue.c) of Salsa20 were vulnerable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1232-1, DSA-4073-1, DSA-4082-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie (security), jessie3.16.56-1+deb8u1fixed
stretch4.9.82-1+deb9u3fixed
stretch (security)4.9.88-1+deb9u1fixed
buster4.16.12-1fixed
sid4.16.16-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.14.7-1high
linuxsourcejessie3.16.51-3+deb8u1highDSA-4082-1
linuxsourcestretch4.9.65-3+deb9u1highDSA-4073-1
linuxsourcewheezy3.2.96-3highDLA-1232-1

Notes

Fixed by: https://git.kernel.org/linus/ecaaab5649781c5a0effdaf298a925063020500e (4.15-rc4)

Search for package or bug name: Reporting problems