CVE-2017-17850

NameCVE-2017-17850
DescriptionAn issue was discovered in Asterisk 13.18.4 and older, 14.7.4 and older, 15.1.4 and older, and 13.18-cert1 and older. A select set of SIP messages create a dialog in Asterisk. Those SIP messages must contain a contact header. For those messages, if the header was not present and the PJSIP channel driver was used, Asterisk would crash. The severity of this vulnerability is somewhat mitigated if authentication is enabled. If authentication is enabled, a user would have to first be authorized before reaching the crash point.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs885072

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
asterisk (PTS)buster1:16.2.1~dfsg-1+deb10u2fixed
buster (security)1:16.28.0~dfsg-0+deb10u1fixed
bullseye1:16.16.1~dfsg-1+deb11u1fixed
bullseye (security)1:16.28.0~dfsg-0+deb11u1fixed
bookworm, sid1:20.0.0~dfsg+~cs6.12.40431414-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
asterisksourcewheezy(not affected)
asterisksourcejessie(not affected)
asterisksourcestretch(not affected)
asterisksource(unstable)1:13.18.5~dfsg-1885072

Notes

[stretch] - asterisk <not-affected> (Vulnerable code introduced after 13.15.0)
[jessie] - asterisk <not-affected> (Vulnerable code introduced after 13.15.0)
[wheezy] - asterisk <not-affected> (Vulnerable code introduced after 13.15.0)
http://downloads.asterisk.org/pub/security/AST-2017-014.html
https://issues.asterisk.org/jira/browse/ASTERISK-27480

Search for package or bug name: Reporting problems