CVE-2017-17913

NameCVE-2017-17913
DescriptionIn GraphicsMagick 1.4 snapshot-20171217 Q8, there is a stack-based buffer over-read in WriteWEBPImage in coders/webp.c, related to an incompatibility with libwebp versions, 0.5.0 and later, that use a different structure type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1fixed
wheezy (security)1.3.16-1.1+deb7u19fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2vulnerable
stretch1.3.25-8vulnerable
buster, sid1.3.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.27-3medium
graphicsmagicksourcewheezy(not affected)

Notes

[wheezy] - graphicsmagick <not-affected> (webp feature has not been implemented)
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/88313ebe379c
http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/6dda3c33f35f
https://sourceforge.net/p/graphicsmagick/bugs/536/

Search for package or bug name: Reporting problems