CVE-2017-17917

NameCVE-2017-17917
Description** DISPUTED ** SQL injection vulnerability in the 'where' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)wheezy2:2.3.14.2vulnerable
jessie (security), jessie2:4.1.8-1+deb8u4vulnerable
stretch2:4.2.7.1-1vulnerable
buster, sid2:4.2.9-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(unfixed)unimportant

Notes

https://kay-malwarebenchmark.github.io/blog/ruby-on-rails-arbitrary-sql-injection/
All of those methods accept arbitrary SQL by design.

Search for package or bug name: Reporting problems