CVE-2017-17919

NameCVE-2017-17919
Description** DISPUTED ** SQL injection vulnerability in the 'order' method in Ruby on Rails 5.1.4 and earlier allows remote attackers to execute arbitrary SQL commands via the 'id desc' parameter. NOTE: The vendor disputes this issue because the documentation states that this method is not intended for use with untrusted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rails (PTS)buster2:5.2.2.1+dfsg-1+deb10u3vulnerable
buster (security)2:5.2.2.1+dfsg-1+deb10u5vulnerable
bullseye2:6.0.3.7+dfsg-2vulnerable
bookworm, sid2:6.1.7+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
railssource(unstable)(unfixed)unimportant

Notes

https://kay-malwarebenchmark.github.io/blog/ruby-on-rails-arbitrary-sql-injection/
All of those methods accept arbitrary SQL by design.

Search for package or bug name: Reporting problems