CVE-2017-17935

NameCVE-2017-17935
DescriptionThe File_read_line function in epan/wslua/wslua_file.c in Wireshark through 2.2.11 does not properly strip '\n' characters, which allows remote attackers to cause a denial of service (buffer underflow and application crash) via a crafted packet that triggers the attempted processing of an empty line.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs885831

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)jessie1.12.1+g01b65bf-4+deb8u14vulnerable
jessie (security)1.12.1+g01b65bf-4+deb8u15vulnerable
stretch (security), stretch2.6.3-1~deb9u1fixed
buster, sid2.6.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.4.4-1medium885831

Notes

[jessie] - wireshark <ignored> (Minor issue)
[wheezy] - wireshark <ignored> (Minor issue)
https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=14295
https://code.wireshark.org/review/#/c/24997/
https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=137ab7d5681486c6d6cc8faac4300b7cd4ec0cf1

Search for package or bug name: Reporting problems