CVE-2017-17942

NameCVE-2017-17942
DescriptionIn LibTIFF 4.0.9, there is a heap-based buffer over-read in the function PackBitsEncode in tif_packbits.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs885579

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)jessie4.0.3-12.3+deb8u5vulnerable
jessie (security)4.0.3-12.3+deb8u6vulnerable
stretch (security), stretch4.0.8-2+deb9u2vulnerable
buster, sid4.0.9-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)(unfixed)medium885579
tiff3source(unstable)(unfixed)medium

Notes

[stretch] - tiff <postponed> (Minor issue, revisit once fixed upstream)
[jessie] - tiff <postponed> (Minor issue, revisit once fixed upstream)
[wheezy] - tiff <postponed> (Minor issue, revisit once fixed upstream)
[wheezy] - tiff3 <postponed> (Minor issue, revisit once fixed upstream)
http://bugzilla.maptools.org/show_bug.cgi?id=2767

Search for package or bug name: Reporting problems