CVE-2017-18009

NameCVE-2017-18009
DescriptionIn OpenCV 3.3.1, a heap-based buffer over-read exists in the function cv::HdrDecoder::checkSignature in modules/imgcodecs/src/grfmt_hdr.cpp.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opencv (PTS)jessie2.4.9.1+dfsg-1+deb8u1fixed
jessie (security)2.4.9.1+dfsg-1+deb8u2fixed
stretch2.4.9.1+dfsg1-2fixed
buster, sid3.2.0+dfsg-4.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opencvsource(unstable)(unfixed)medium
opencvsourcejessie(not affected)
opencvsourcestretch(not affected)
opencvsourcewheezy(not affected)

Notes

[stretch] - opencv <not-affected> (Vulnerable code introduced later)
[jessie] - opencv <not-affected> (Vulnerable code introduced later)
[wheezy] - opencv <not-affected> (Vulnerable code introduced later)
https://github.com/opencv/opencv/issues/10479
Introduced after: https://github.com/opencv/opencv/commit/7469c935f3ec8e9fe4f56b7eed07b284b7b7b5df

Search for package or bug name: Reporting problems