CVE-2017-18026

NameCVE-2017-18026
DescriptionRedmine before 3.2.9, 3.3.x before 3.3.6, and 3.4.x before 3.4.4 does not block the --config and --debugger flags to the Mercurial hg program, which allows remote attackers to execute arbitrary commands (through the Mercurial adapter) via vectors involving a branch whose name begins with a --config= or --debugger= substring, a related issue to CVE-2017-17536.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs887307

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redmine (PTS)wheezy1.4.4+dfsg1-2+deb7u1vulnerable
jessie3.0~20140825-8~deb8u4vulnerable
jessie (security)3.0~20140825-8~deb8u2vulnerable
stretch3.3.1-4vulnerable
sid3.4.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redminesource(unstable)(unfixed)887307
redminesourcewheezy(unfixed)end-of-life

Notes

[wheezy] - redmine <end-of-life> (Not supported in wheezy LTS)
https://www.redmine.org/issues/27516 (private)
https://github.com/redmine/redmine/commit/ca87bf766cdc70179cb2dce03015d78ec9c13ebd
https://github.com/redmine/redmine/commit/58ed8655136ff2fe5ff7796859bf6a399c76c678
https://github.com/redmine/redmine/commit/9d797400eaec5f9fa7ba9507c82d9c18cb91d02e
upstream fixed in 3.2.9, 3.3.6 and 3.4.4

Search for package or bug name: Reporting problems