CVE-2017-18043

NameCVE-2017-18043
DescriptionInteger overflow in the macro ROUND_UP (n, d) in Quick Emulator (Qemu) allows a user to cause a denial of service (Qemu process crash).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1497-1, DSA-4213-1
NVD severitylow (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u7fixed
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.10.0+dfsg-2low
qemusourcejessie1:2.1+dfsg-12+deb8u7lowDLA-1497-1
qemusourcestretch1:2.8+dfsg-6+deb9u4lowDSA-4213-1
qemusourcewheezy(not affected)
qemu-kvmsource(unstable)(unfixed)low
qemu-kvmsourcewheezy(not affected)

Notes

[wheezy] - qemu <not-affected> (vulnerable code not present)
[wheezy] - qemu-kvm <not-affected> (vulnerable code not present)
Fixed by: https://git.qemu.org/?p=qemu.git;a=commit;h=2098b073f398cd628c09c5a78537a6854
Broken since: https://git.qemu.org/?p=qemu.git;a=object;h=292c8e50 (v1.5.0)
Fix included in 1:2.10.0+dfsg-2 via debian/patches/qemu-2.10.1.diff patch

Search for package or bug name: Reporting problems