CVE-2017-18077

NameCVE-2017-18077
Descriptionindex.js in brace-expansion before 1.1.7 is vulnerable to Regular Expression Denial of Service (ReDoS) attacks, as demonstrated by an expand argument containing many comma characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs862712

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-brace-expansion (PTS)stretch1.1.6-1+deb9u1fixed
buster, sid1.1.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-brace-expansionsource(unstable)1.1.8-1unimportant862712
node-brace-expansionsourcestretch1.1.6-1+deb9u1medium

Notes

https://nodesecurity.io/advisories/338
https://github.com/juliangruber/brace-expansion/issues/33
https://github.com/juliangruber/brace-expansion/pull/35/commits/b13381281cead487cbdbfd6a69fb097ea5e456c3
nodejs not covered by security support

Search for package or bug name: Reporting problems