CVE-2017-18121

NameCVE-2017-18121
DescriptionThe consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1273-1, DSA-4127-1
NVD severitymedium
Debian Bugs889286

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
simplesamlphp (PTS)jessie1.13.1-2+deb8u1fixed
jessie (security)1.13.1-2+deb8u3fixed
stretch1.14.11-1+deb9u1fixed
stretch (security)1.14.11-1+deb9u2fixed
buster, buster (security)1.16.3-1+deb10u1fixed
bullseye, sid1.18.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
simplesamlphpsource(unstable)1.15.0-1889286
simplesamlphpsourcejessie1.13.1-2+deb8u1DSA-4127-1
simplesamlphpsourcestretch1.14.11-1+deb9u1DSA-4127-1
simplesamlphpsourcewheezy1.9.2-1+deb7u2DLA-1273-1

Notes

https://simplesamlphp.org/security/201709-01
https://github.com/simplesamlphp/simplesamlphp/commit/34e1bdb7660c0c9b627f8e5f0ca224a6afe641a8 (v1.14.16)

Search for package or bug name: Reporting problems