CVE-2017-18184

NameCVE-2017-18184
DescriptionAn issue was discovered in QPDF before 7.0.0. There is a stack-based out-of-bounds read in the function iterate_rc4 in QPDF_encryption.cc.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qpdf (PTS)buster8.4.0-2fixed
buster (security)8.4.0-2+deb10u1fixed
bullseye10.1.0-1fixed
bookworm11.3.0-1+deb12u1fixed
trixie, sid11.8.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qpdfsource(unstable)7.0.0-1

Notes

[stretch] - qpdf <no-dsa> (Minor issue)
[jessie] - qpdf <no-dsa> (Minor issue)
[wheezy] - qpdf <no-dsa> (Minor issue)
https://github.com/qpdf/qpdf/commit/dea704f0ab7f625e1e7b3f9a1110b45b63157317
https://github.com/qpdf/qpdf/issues/147

Search for package or bug name: Reporting problems