CVE-2017-18187

NameCVE-2017-18187
DescriptionIn ARM mbed TLS before 2.7.0, there is a bounds-check bypass through an integer overflow in PSK identity parsing in the ssl_parse_client_psk_identity() function in library/ssl_srv.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4138-1, DSA-4147-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mbedtls (PTS)stretch (security), stretch2.4.2-1+deb9u3fixed
buster2.13.0-3fixed
sid2.14.1-2fixed
polarssl (PTS)jessie1.3.9-2.1+deb8u3fixed
jessie (security)1.3.9-2.1+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mbedtlssource(unstable)2.7.0-2high
mbedtlssourcestretch2.4.2-1+deb9u2highDSA-4138-1
polarsslsource(unstable)(unfixed)high
polarsslsourcejessie1.3.9-2.1+deb8u3highDSA-4147-1
polarsslsourcewheezy(not affected)

Notes

[wheezy] - polarssl <not-affected> (vulnerable code not present)
https://github.com/ARMmbed/mbedtls/commit/83c9f495ffe70c7dd280b41fdfd4881485a3bc28

Search for package or bug name: Reporting problems