CVE-2017-18198

NameCVE-2017-18198
Descriptionprint_iso9660_recurse in iso-info.c in GNU libcdio before 1.0.0 allows remote attackers to cause a denial of service (heap-based buffer over-read) or possibly have unspecified other impact via a crafted iso file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcdio (PTS)jessie0.83-4.2vulnerable
stretch0.83-4.3vulnerable
bullseye, sid, buster2.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcdiosource(unstable)1.0.0-1low

Notes

[stretch] - libcdio <no-dsa> (Minor issue)
[jessie] - libcdio <no-dsa> (Minor issue)
[wheezy] - libcdio <no-dsa> (Minor issue)
https://savannah.gnu.org/bugs/?52265

Search for package or bug name: Reporting problems