CVE-2017-18201

NameCVE-2017-18201
DescriptionAn issue was discovered in GNU libcdio before 2.0.0. There is a double free in get_cdtext_generic() in lib/driver/_cdio_generic.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs891638

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcdio (PTS)jessie0.83-4.2fixed
stretch0.83-4.3fixed
buster, sid2.0.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcdiosource(unstable)(unfixed)high891638
libcdiosourceexperimental2.0.0-1high
libcdiosourcejessie(not affected)
libcdiosourcestretch(not affected)
libcdiosourcewheezy(not affected)

Notes

[stretch] - libcdio <not-affected> (Vulnerable code introduced post 0.92)
[jessie] - libcdio <not-affected> (Vulnerable code introduced post 0.92)
[wheezy] - libcdio <not-affected> (Vulnerable code introduced post 0.92)
Fixed by https://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=f6f9c48fb40b8a1e8218799724b0b61a7161eb1d
with https://git.savannah.gnu.org/cgit/libcdio.git/commit/?id=dec2f876c2d7162da213429bce1a7140cdbdd734

Search for package or bug name: Reporting problems