CVE-2017-18212

NameCVE-2017-18212
DescriptionAn issue was discovered in JerryScript 1.0. There is a heap-based buffer over-read in the lit_read_code_unit_from_hex function in lit/lit-char-helpers.c via a RegExp("[\x0"); payload.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
iotjs (PTS)buster1.0-1vulnerable
bullseye, sid1.0+715-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iotjssource(unstable)1.0+715-1

Notes

[buster] - iotjs <no-dsa> (Minor issue)
https://github.com/jerryscript-project/jerryscript/issues/2140

Search for package or bug name: Reporting problems